On Sun, 2007-03-04 at 19:59 +0100, Arnd Bergmann wrote:
On Sunday 04 March 2007, Benjamin Herrenschmidt wrote:
quoted
On Sun, 2007-03-04 at 15:07 +0100, Arnd Bergmann wrote:
quoted
On Sunday 04 March 2007 07:04:44 Stephen Rothwell wrote:
quoted
config PCI
bool "PCI support" if 40x || CPM2 || PPC_83xx || PPC_85xx || PPC_86xx \
- || PPC_MPC52xx || (EMBEDDED && PPC_ISERIES) || MPC7448HPC2 || PPC_PS3
+ || PPC_MPC52xx || (EMBEDDED && (PPC_PSERIES || PPC_ISERIES)) \
+ || MPC7448HPC2 || PPC_PS3
I dislike the giant conditional though.
How about changing it to
config PCI_ENABLE
bool
Call it PCI_CAPABLE rather...
Ben.