Re: [PATCH 10/35] fabrics: export do_discover(), build_options() and config
From: Martin Wilck <hidden>
Date: 2021-02-04 09:21:20
On Thu, 2021-02-04 at 08:09 +0100, Hannes Reinecke wrote:
On 1/26/21 9:32 PM, mwilck@suse.com wrote:quoted
+/* Symbols used by monitor.c */ + +struct config { + char *nqn; + char *transport; + char *traddr; + char *trsvcid; + char *host_traddr; + char *hostnqn; + char *hostid; + int nr_io_queues; + int nr_write_queues; + int nr_poll_queues; + int queue_size; + int keep_alive_tmo; + int reconnect_delay; + int ctrl_loss_tmo; + int tos; + char *raw; + char *device; + int duplicate_connect; + int disable_sqflow; + int hdr_digest; + int data_digest; + bool persistent; + bool matching_only; +}; +extern struct config cfg; + +#define BUF_SIZE 4096 + +int build_options(char *argstr, int max_len, bool discover); +int do_discover(char *argstr, bool connect); + #endifPlease name is 'struct config fabrics_cfg'. 'cfg' is used as a generic name throughout the code, and using the same name in a header might lead to an accidental name clash.
Will do (the reason I didn't in the first place was that I wanted to minimize changes of existing code, but you're right of course). Thanks, Martin _______________________________________________ Linux-nvme mailing list Linux-nvme@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-nvme