On Wed, Jun 23, 2021 at 11:58:02AM +0200, Christoph Hellwig wrote:
On Tue, Jun 22, 2021 at 01:15:46PM +0100, Matthew Wilcox (Oracle) wrote:
quoted
+static inline
+struct folio *__alloc_folio_node(gfp_t gfp, unsigned int order, int nid)
Weirdo prototype formatting.
Otherwise looks good (assuming we grow callers):
The next patch adds filemap_alloc_folio() which uses these. That then
gets used in "mm/filemap: Add filemap_get_folio", which is the patch
after that.
Now that I look at this patch again, I wonder if this shouldn't be
folio_alloc(), __folio_alloc() and __folio_alloc_node. And even though
I have no users yet, completing the set with folio_alloc_node() might
be a good idea.
Reviewed-by: Christoph Hellwig <hch@lst.de>