On Tue, Jun 22, 2021 at 01:15:29PM +0100, Matthew Wilcox (Oracle) wrote:
test_clear_page_writeback() is actually an mm-internal function, although
it's named as if it's a pagecache function. Move it to mm/internal.h,
rename it to __folio_end_writeback() and change the return type to bool.
The conversion from page to folio is mostly about accounting the number
of pages being written back, although it does eliminate a couple of
calls to compound_head().
While this looks good, I think the whole abstraction is wrong. I think
test_clear_page_writeback should just be merged into it's only caller.
But if that is somehow not on the table this change looks ok:
Reviewed-by: Christoph Hellwig <hch@lst.de>