Thread (128 messages) 128 messages, 3 authors, 2021-06-28

Re: [PATCH v2 14/46] mm/memcg: Add folio_charge_cgroup()

From: Matthew Wilcox <willy@infradead.org>
Date: 2021-06-24 16:43:46
Also in: linux-fsdevel, lkml

On Wed, Jun 23, 2021 at 10:15:20AM +0200, Christoph Hellwig wrote:
On Tue, Jun 22, 2021 at 01:15:19PM +0100, Matthew Wilcox (Oracle) wrote:
quoted
mem_cgroup_charge() already assumed it was being passed a non-tail
page (and looking at the callers, that's true; it's called for freshly
allocated pages).  The only real change here is that folio_nr_pages()
doesn't compile away like thp_nr_pages() does as folio support
is not conditional on transparent hugepage support.  Reimplement
mem_cgroup_charge() as a wrapper around folio_charge_cgroup().
Maybe rename __mem_cgroup_charge to __folio_charge_cgroup as well?
Oh, yeah, should have done that.  Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help