Re: [PATCH v5 1/5] mm,memory_hotplug: Allocate memmap from the added memory range
From: David Hildenbrand <hidden>
Date: 2021-03-25 16:21:24
Also in:
lkml
From: David Hildenbrand <hidden>
Date: 2021-03-25 16:21:24
Also in:
lkml
On 25.03.21 17:07, Michal Hocko wrote:
On Thu 25-03-21 16:35:58, Michal Hocko wrote: [...]quoted
So there is indeed a difference. One way around that would be to mark vmemmap pages (e.g. PageReserved && magic value stored somewhere in the struct page - resembling bootmem vmemmaps) or mark section fully backing vmemmaps as online (ugly).I am not yet ready to give up on this. Here is a quick stab at the pfn_to_online_page approach. It is not great but it is not really terrible either. I think we can do better and skip
We both seem to have a different taste, to phrase it in a nice way :) ; but well, you seem to have set your mind (just like I seem to have set mine when trying to find a nice and somewhat-clean way to handle this when discussing it in the past). I expressed my opinion, shared my findings and expressed my concerns; the series has my RB and the discussion here is around something I consider in no way better than what we have right now. I'll let Oscar handle discussing this topic further (sorry Oscar! :) ), but I'll happily review what the outcome of that will be. -- Thanks, David / dhildenb