Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3
From: Ingo Molnar <mingo@kernel.org>
Date: 2016-01-11 10:51:11
Also in:
lkml
From: Ingo Molnar <mingo@kernel.org>
Date: 2016-01-11 10:51:11
Also in:
lkml
* Linus Torvalds [off-list ref] wrote:
quoted
quoted
Or is there some reason you wanted the odd flags version? If so, that should be documented.What do you mean "odd"?It's odd because it makes no sense for non-pcid (christ, I wish Intel had just called it "asid" instead, "pcid" always makes me react to "pci"), and I think it would make more sense to pair up the pcid case with the invpcid rather than have those preemption rules here.
The naming is really painful, so a trivial suggestion: could we just name all the Linux side bits 'asid' or 'ctx_id' (even in x86 arch code) and only use 'PCID' nomenclature in the very lowest level code? I.e. rename pcid_live_cpus et al and most functions to the asid or ctx_id or asid naming scheme or so. That would hide most of the naming ugliness. Thanks, Ingo -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>