Thread (37 messages) 37 messages, 6 authors, 2011-09-05

Re: [PATCH 08/13] list: add a new LRU list type

From: Konstantin Khlebnikov <hidden>
Date: 2011-08-23 09:58:50
Also in: linux-fsdevel, lkml

Dave Chinner wrote:
On Tue, Aug 23, 2011 at 05:20:56AM -0400, Christoph Hellwig wrote:
quoted
On Tue, Aug 23, 2011 at 06:56:21PM +1000, Dave Chinner wrote:
quoted
From: Dave Chinner<redacted>

Several subsystems use the same construct for LRU lists - a list
head, a spin lock and and item count. They also use exactly the same
code for adding and removing items from the LRU. Create a generic
type for these LRU lists.

This is the beginning of generic, node aware LRUs for shrinkers to
work with.
Why list_lru vs the more natural sounding lru_list?
because the mmzone.h claimed that namespace:

enum lru_list {
         LRU_INACTIVE_ANON = LRU_BASE,
         LRU_ACTIVE_ANON = LRU_BASE + LRU_ACTIVE,
         LRU_INACTIVE_FILE = LRU_BASE + LRU_FILE,
         LRU_ACTIVE_FILE = LRU_BASE + LRU_FILE + LRU_ACTIVE,
         LRU_UNEVICTABLE,
         NR_LRU_LISTS
};

and it is widely spewed through the mm code. I didn't really feel
like having to clean that mess up first....
not so widely:

$ git grep -wc 'enum lru_list'
include/linux/memcontrol.h:5
include/linux/mm_inline.h:7
include/linux/mmzone.h:4
include/linux/pagevec.h:1
include/linux/swap.h:2
mm/memcontrol.c:10
mm/page_alloc.c:1
mm/swap.c:6
mm/vmscan.c:6

maybe is better to rename it to enum page_lru_list

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help