Thread (73 messages) 73 messages, 6 authors, 2017-05-24

Re: [PATCH 11/31] block: Introduce queue flag QUEUE_FLAG_SCSI_SUP

From: Bart Van Assche <hidden>
Date: 2017-05-24 15:05:28
Also in: linux-scsi

On Wed, 2017-05-24 at 08:01 +0200, Hannes Reinecke wrote:
On 05/24/2017 02:34 AM, Bart Van Assche wrote:
quoted
From the context where a SCSI command is submitted it is not always
possible to figure out whether or not the queue the command is
submitted to has struct scsi_request as the first member of its
private data. Hence introduce the flag QUEUE_FLAG_SCSI_SUP.
=20
Signed-off-by: Bart Van Assche <redacted>
Cc: Jens Axboe <axboe@fb.com>
Cc: Christoph Hellwig <hch@lst.de>
Cc: Omar Sandoval <redacted>
Cc: Hannes Reinecke <hare@suse.com>
---
 block/bsg-lib.c                   | 1 +
 drivers/block/cciss.c             | 1 +
 drivers/ide/ide-probe.c           | 1 +
 drivers/scsi/scsi_lib.c           | 2 ++
 drivers/scsi/scsi_transport_sas.c | 1 +
 include/linux/blkdev.h            | 2 ++
 6 files changed, 8 insertions(+)
=20
=20
Bit of an odd name; what about QUEUE_FLAG_SCSI_PDU?
Hello Hannes,

That sounds like a good idea to me. I will rename the flag when I repost th=
is
series.

Bart.=
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help