Re: [PATCH 02/11] drm/mediatek: Rename "mtk_drm_ddp_comp" to "mtk_ddp_comp"
From: CK Hu (胡俊光) <hidden>
Date: 2024-03-14 05:14:26
Also in:
dri-devel, linux-media, linux-mediatek, lkml
Hi, Shawn: On Mon, 2024-02-26 at 16:50 +0800, Shawn Sung wrote:
From: Hsiao Chien Sung <redacted> Rename all "mtk_drm_ddp_comp" to "mtk_ddp_comp": - To align the naming rule - To reduce the code size
Reviewed-by: CK Hu <redacted>
quoted hunk ↗ jump to hunk
Signed-off-by: Hsiao Chien Sung < shawn.sung@mediatek.corp-partner.google.com> --- drivers/gpu/drm/mediatek/mtk_drm_crtc.c | 16 +++++++--------- drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.h | 6 +++--- 2 files changed, 10 insertions(+), 12 deletions(-)diff --git a/drivers/gpu/drm/mediatek/mtk_drm_crtc.cb/drivers/gpu/drm/mediatek/mtk_drm_crtc.c index fe965ad7d282..d8b591aff3c2 100644--- a/drivers/gpu/drm/mediatek/mtk_drm_crtc.c +++ b/drivers/gpu/drm/mediatek/mtk_drm_crtc.c@@ -276,9 +276,9 @@ static void mtk_crtc_ddp_clk_disable(structmtk_crtc *mtk_crtc) } static -struct mtk_ddp_comp *mtk_drm_ddp_comp_for_plane(struct drm_crtc *crtc, - struct drm_plane *plane, - unsigned int *local_layer) +struct mtk_ddp_comp *mtk_ddp_comp_for_plane(struct drm_crtc *crtc, + struct drm_plane *plane, + unsigned int *local_layer) { struct mtk_crtc *mtk_crtc = to_mtk_crtc(crtc); struct mtk_ddp_comp *comp;@@ -428,7 +428,7 @@ static int mtk_crtc_ddp_hw_init(struct mtk_crtc*mtk_crtc) /* should not enable layer before crtc enabled */ plane_state->pending.enable = false; - comp = mtk_drm_ddp_comp_for_plane(crtc, plane, &local_layer); + comp = mtk_ddp_comp_for_plane(crtc, plane, &local_layer); if (comp) mtk_ddp_comp_layer_config(comp, local_layer, plane_state, NULL);@@ -519,8 +519,7 @@ static void mtk_crtc_ddp_config(struct drm_crtc*crtc, if (!plane_state->pending.config) continue; - comp = mtk_drm_ddp_comp_for_plane(crtc, plane, - &local_layer) ; + comp = mtk_ddp_comp_for_plane(crtc, plane, &local_layer); if (comp) mtk_ddp_comp_layer_config(comp, local_layer,@@ -544,8 +543,7 @@ static void mtk_crtc_ddp_config(struct drm_crtc*crtc, if (!plane_state->pending.async_config) continue; - comp = mtk_drm_ddp_comp_for_plane(crtc, plane, - &local_layer) ; + comp = mtk_ddp_comp_for_plane(crtc, plane, &local_layer); if (comp) mtk_ddp_comp_layer_config(comp, local_layer,@@ -709,7 +707,7 @@ int mtk_crtc_plane_check(struct drm_crtc *crtc,struct drm_plane *plane, unsigned int local_layer; struct mtk_ddp_comp *comp; - comp = mtk_drm_ddp_comp_for_plane(crtc, plane, &local_layer); + comp = mtk_ddp_comp_for_plane(crtc, plane, &local_layer); if (comp) return mtk_ddp_comp_layer_check(comp, local_layer, state); return 0;diff --git a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.hb/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.h index 93d79a1366e9..ba985206fdd2 100644--- a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.h +++ b/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.h@@ -3,8 +3,8 @@ * Copyright (c) 2015 MediaTek Inc. */ -#ifndef MTK_DRM_DDP_COMP_H -#define MTK_DRM_DDP_COMP_H +#ifndef MTK_DDP_COMP_H +#define MTK_DDP_COMP_H #include <linux/io.h> #include <linux/pm_runtime.h>@@ -340,4 +340,4 @@ void mtk_ddp_write_relaxed(struct cmdq_pkt*cmdq_pkt, unsigned int value, void mtk_ddp_write_mask(struct cmdq_pkt *cmdq_pkt, unsigned int value, struct cmdq_client_reg *cmdq_reg, void __iomem *regs, unsigned int offset, unsigned int mask); -#endif /* MTK_DRM_DDP_COMP_H */ +#endif /* MTK_DDP_COMP_H */
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel