RE: [PATCH 03/19] dt-bindings: bus: add CDX bus controller device tree bindings
From: "Gupta, Nipun" <Nipun.Gupta@amd.com>
Date: 2023-01-19 07:33:42
Also in:
linux-devicetree, linux-kbuild, lkml
-----Original Message----- From: Krzysztof Kozlowski <redacted> Sent: Wednesday, January 18, 2023 6:13 PM To: Gupta, Nipun <Nipun.Gupta@amd.com>; robh+dt@kernel.org; krzysztof.kozlowski+dt@linaro.org; gregkh@linuxfoundation.org; rafael@kernel.org; eric.auger@redhat.com; alex.williamson@redhat.com; cohuck@redhat.com; song.bao.hua@hisilicon.com; mchehab+huawei@kernel.org; maz@kernel.org; f.fainelli@gmail.com; jeffrey.l.hugo@gmail.com; saravanak@google.com; Michael.Srba@seznam.cz; mani@kernel.org; yishaih@nvidia.com; jgg@ziepe.ca; jgg@nvidia.com; robin.murphy@arm.com; will@kernel.org; joro@8bytes.org; masahiroy@kernel.org; ndesaulniers@google.com; linux-arm- kernel@lists.infradead.org; linux-kbuild@vger.kernel.org; linux- kernel@vger.kernel.org; devicetree@vger.kernel.org Cc: okaya@kernel.org; Anand, Harpreet <redacted>; Agarwal, Nikhil [off-list ref]; Simek, Michal [off-list ref]; git (AMD-Xilinx) [off-list ref] Subject: Re: [PATCH 03/19] dt-bindings: bus: add CDX bus controller device tree bindings
(...)
quoted
quoted
quoted
+properties: + compatible: + const: xlnx,cdxbus-controllerThis misses SoC specific compatible. Drop "bus" - redundant. I would also say - drop controller - do you see any other devices with such compatible naming? Use naming consistent with other devices in the kernel. Just open some controllers - SPI, I2C etc. and look there.Makes sense. Will use "xlnx,cdx" in compatible.No, this still misses device specific compatible. You did ignored half of my comment now.
Sorry I missed that part. Will rename this to "xlnx,versal-cdx". Thanks, Nipun
Best regards, Krzysztof
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel