Re: [PATCH 1/8] revert: prepare to move replay_action to header
From: Jonathan Nieder <hidden>
Date: 2016-06-15 22:52:45
Ramkumar Ramachandra wrote:
Later in the series, we will build a generalized sequencer by factoring code out of the revert builtin, and leaving it with just argument parsing work. This involves moving "replay_action" to sequencer.h, so that both sequencer.c and builtin/revert.c can use it. Unfortunately, "REVERT" and "CHERRY_PICK" are unsuitable variable names, as their purpose is unclear in the global context; in anticipation of the move, rename them to "REPLAY_REVERT" and "REPLAY_PICK" respectively.
This could be pruned to just the final bit. Something like: REVERT and CHERRY_PICK and are unsuitable names for an enumerator in a public interface, because they are generic enough to be likely to clash with identifiers with other meanings. Rename to REPLAY_REVERT and REPLAY_PICK as preparation for exposing them. The patch proper looks safe and the effect positive to me, so I would be all for applying it as long as the commit message is cleaned up.