Jonathan Nieder wrote:
Ramkumar Ramachandra wrote:
quoted
So, while a future
instruction sheet would look like:
pick next~4
action3 b74fea
revert rr/moo^2~34
the actions "pick", "action3" and "revert" need not necessarily
correspond to the specific builtins.
So what change does the patch actually make? Is this a renaming?
Yes, it renames "action" to "command" where appropriate.
[...]
quoted
--- a/builtin/revert.c
+++ b/builtin/revert.c
[...]
quoted
@@ -64,16 +64,21 @@ struct replay_opts {
#define GIT_REFLOG_ACTION "GIT_REFLOG_ACTION"
-static const char *action_name(const struct replay_opts *opts)
+static const char *command_name(struct replay_opts *opts)
Why is the const being dropped? I'm lost, so not reading further.
Minor error. The rest of the patch should be fine.
-- Ram