Thread (339 messages) 339 messages, 17 authors, 2021-10-17

Re: [dpdk-dev] [RFC UPDATE PATCH 0/9] dmadev rfc suggested updates

From: Bruce Richardson <hidden>
Date: 2021-07-07 08:11:46

On Wed, Jul 07, 2021 at 11:16:44AM +0800, fengchengwen wrote:
LGTM, thanks

And I'am prepare dmadev V2, include:
a) Fix code review comments (e.g. multiple-process support, doxygen, comments, typo)
b) Flatten device abstraction to two layer: dmadev <> vchan
c) Public API use dev_id and vchan_id to locate one vchan
d) Using the flags parameter instead of the fence API
Bit uncertain about this one still
e) Rename rte_dmadev_perform to rte_dmadev_submit so it corresponds to the stats variable.

PS: Some code (lib/dmadev) will rebase this patchset
This was not meant to be a separate patchset, but rather to try and keep us
all in sync on what was being looked at and tested. Please just pull in the
changes from this set (as many as you are happy with) into your V2 RFC to
simplify things. It's better to just have the one master RFC into which
changes are pulled.

Thanks,
/Bruce
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help