Thread (92 messages) 92 messages, 4 authors, 2012-06-17

Re: [ 31/82] mm/vmalloc.c: change void* into explict vm_struct*

From: Ben Hutchings <hidden>
Date: 2012-06-08 12:16:27
Also in: lkml

On Fri, 2012-06-08 at 03:41 -0700, David Rientjes wrote:
On Fri, 8 Jun 2012, Ben Hutchings wrote:
quoted
3.2-stable review patch.  If anyone has any objections, please let me know.

------------------

From: Minchan Kim <minchan@kernel.org>

commit db1aecafef58b5dda39c4228debe2c845e4a27ab upstream.

vmap_area->private is void* but we don't use the field for various purpose
but use only for vm_struct.  So change it to a vm_struct* with naming to
improve for readability and type checking.

Signed-off-by: Minchan Kim <minchan@kernel.org>
Acked-by: David Rientjes <rientjes@google.com>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Signed-off-by: Ben Hutchings <redacted>
I'm not sure this is stable material and it wasn't annotated as such when 
it was commited, why should someone need to upgrade their 3.2 for a patch 
like this?
It allows the next one (commit dbda591d920b4c7692725b13e3f68ecb251e9080,
'mm: fix faulty initialization in vmalloc_init()') apply cleanly.  So,
unless it causes some harm, I'll keep it.

Ben.

-- 
Ben Hutchings
I haven't lost my mind; it's backed up on tape somewhere.

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help