Re: [ 31/82] mm/vmalloc.c: change void* into explict vm_struct*
From: David Rientjes <rientjes@google.com>
Date: 2012-06-08 10:42:02
Also in:
lkml
From: David Rientjes <rientjes@google.com>
Date: 2012-06-08 10:42:02
Also in:
lkml
On Fri, 8 Jun 2012, Ben Hutchings wrote:
3.2-stable review patch. If anyone has any objections, please let me know. ------------------ From: Minchan Kim <minchan@kernel.org> commit db1aecafef58b5dda39c4228debe2c845e4a27ab upstream. vmap_area->private is void* but we don't use the field for various purpose but use only for vm_struct. So change it to a vm_struct* with naming to improve for readability and type checking. Signed-off-by: Minchan Kim <minchan@kernel.org> Acked-by: David Rientjes <rientjes@google.com> Signed-off-by: Andrew Morton <akpm@linux-foundation.org> Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org> Signed-off-by: Ben Hutchings <redacted>
I'm not sure this is stable material and it wasn't annotated as such when it was commited, why should someone need to upgrade their 3.2 for a patch like this?