There is a degree of inconsistency, nuisance and ambiguity in the naming
of the zcrx "notification" API. Rename it to "events" and do other small
adjustments while it's not released yet. The patch set only does
renaming, there is no functional or ABI changes.
Pavel Begunkov (3):
io_uring/zcrx: drop "notif" from stats struct names
io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
io_uring/zcrx: rename notif to event
include/uapi/linux/io_uring/query.h | 14 ++++++------
include/uapi/linux/io_uring/zcrx.h | 32 +++++++++++++--------------
io_uring/query.c | 12 +++++-----
io_uring/zcrx.c | 34 ++++++++++++++---------------
io_uring/zcrx.h | 7 +++---
5 files changed, 50 insertions(+), 49 deletions(-)
--
2.54.0