Re: [PATCH net-next v3 04/11] netlink: specs: add specification for wireguard
From: Asbjørn Sloth Tønnesen <hidden>
Date: 2025-11-18 22:00:36
Also in:
lkml
On 11/18/25 3:07 PM, Jason A. Donenfeld wrote:
On Tue, Nov 18, 2025 at 12:08:20PM +0000, Asbjørn Sloth Tønnesen wrote:quoted
quoted
There's lots of control over the C output here. Why can't there also be a top-level c-function-prefix attribute, so that patch 10/11 is unnecessary? Stack traces for wireguard all include wg_; why pollute this with the new "wireguard_" ones?It could also be just "c-prefix".Works for me.
Unfortunately, it isn't that simple.
The functions are defined as:
name = c_lower(f"{family.ident_name}-nl-{op_name}-doit")
name = c_lower(f"{family.ident_name}-nl-{op_name}-dumpit")
and
name = c_lower(f"{family.ident_name}-nl-{op_name}-{op_mode}it")
The "c-prefix" would replace "family.ident_name" aka. "wireguard",
but the "-nl-" would remain, which isn't in the current naming.
So "c-function-prefix" or something might work better.
My idea with "c-prefix" was to also cover the family and version defines,
but they are eg. WG_GENL_NAME where the default would be *_FAMILY_NAME.
quoted
quoted
quoted
+ dump: + pre: wireguard-nl-get-device-start + post: wireguard-nl-get-device-doneOh, or, the wg_ prefix can be defined here (instead of wireguard_, per my 10/11 comment above).The key here is the missing ones, I renamed these for alignment with doit and dumpit which can't be customized at this time.Oh, interesting. So actually, the c-prefix thing would let you ditch this too, and it'd be more consistent.
The pre and post still needs to be defined as they aren't used by default.