Thread (22 messages) flat view 22 messages, 4 authors, 2025-08-25

Re: [PATCH net-next 00/15] Aquantia PHY driver consolidation - part 1

From: patchwork-bot+netdevbpf@kernel.org
Date: 2025-08-25 18:00:16
Also in: lkml

Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski [off-list ref]:

On Thu, 21 Aug 2025 18:20:07 +0300 you wrote:
This started out as an effort to add some new features hinging on the
VEND1_GLOBAL_CFG_* registers, but I quickly started to notice that the
Aquantia PHY driver has a large code base, but individual PHYs only
implement arbitrary subsets of it.

The table below lists the PHYs known to me to have the
VEND1_GLOBAL_CFG_* registers.

[...]
Here is the summary with links:
  - [net-next,01/15] net: phy: aquantia: rename AQR412 to AQR412C and add real AQR412
    https://git.kernel.org/netdev/net-next/c/7cd3597b8f6f
  - [net-next,02/15] net: phy: aquantia: merge aqr113c_fill_interface_modes() into aqr107_fill_interface_modes()
    https://git.kernel.org/netdev/net-next/c/a31b1c1591e8
  - [net-next,03/15] net: phy: aquantia: reorder AQR113C PMD Global Transmit Disable bit clearing with supported_interfaces
    https://git.kernel.org/netdev/net-next/c/5433fbc3adcd
  - [net-next,04/15] net: phy: aquantia: rename some aqr107 functions according to generation
    https://git.kernel.org/netdev/net-next/c/9731bcf202e6
  - [net-next,05/15] net: phy: aquantia: fill supported_interfaces for all aqr_gen2_config_init() callers
    https://git.kernel.org/netdev/net-next/c/ab1dfcb5bce1
  - [net-next,06/15] net: phy: aquantia: save a local shadow of GLOBAL_CFG register values
    https://git.kernel.org/netdev/net-next/c/08048ba4285e
  - [net-next,07/15] net: phy: aquantia: remove handling for get_rate_matching(PHY_INTERFACE_MODE_NA)
    https://git.kernel.org/netdev/net-next/c/6fa022088b60
  - [net-next,08/15] net: phy: aquantia: use cached GLOBAL_CFG registers in aqr107_read_rate()
    https://git.kernel.org/netdev/net-next/c/832b63c70ef0
  - [net-next,09/15] net: phy: aquantia: merge and rename aqr105_read_status() and aqr107_read_status()
    https://git.kernel.org/netdev/net-next/c/c03c97e55f62
  - [net-next,10/15] net: phy: aquantia: call aqr_gen2_fill_interface_modes() for AQCS109
    https://git.kernel.org/netdev/net-next/c/02a7f5a92545
  - [net-next,11/15] net: phy: aquantia: call aqr_gen3_config_init() for AQR112 and AQR412(C)
    https://git.kernel.org/netdev/net-next/c/2d9503217520
  - [net-next,12/15] net: phy: aquantia: reimplement aqcs109_config_init() as aqr_gen2_config_init()
    https://git.kernel.org/netdev/net-next/c/ed1106f7f926
  - [net-next,13/15] net: phy: aquantia: rename aqr113c_config_init() to aqr_gen4_config_init()
    https://git.kernel.org/netdev/net-next/c/3c904dd67f50
  - [net-next,14/15] net: phy: aquantia: promote AQR813 and AQR114C to aqr_gen4_config_init()
    https://git.kernel.org/netdev/net-next/c/9dfe80a8157b
  - [net-next,15/15] net: phy: aquantia: add support for AQR115
    https://git.kernel.org/netdev/net-next/c/fb4b9f13718c

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help