Thread (22 messages) flat view 22 messages, 4 authors, 2025-08-25

Re: [PATCH net-next 02/15] net: phy: aquantia: merge aqr113c_fill_interface_modes() into aqr107_fill_interface_modes()

From: Andrew Lunn <andrew@lunn.ch>
Date: 2025-08-21 16:20:55
Also in: lkml

On Thu, Aug 21, 2025 at 06:20:09PM +0300, Vladimir Oltean wrote:
I'm unsure whether intentionate or not, but I think the (partially
observed) naming convention in this driver is that function prefixes
denote the earliest generation when a feature is available. In case of
aqr107_fill_interface_modes(), that means that the GLOBAL_CFG registers
are a Gen2 feature. Supporting evidence: the AQR105, a Gen1 PHY, does
not have these registers, thus the function is not named aqr105_*.
That is reasonably common. The Marvell PHY and DSA driver use the
same.

The other option would be to use gen1_, gen2_, gen3_ prefixes.

The Broadcom PHY uses an odd naming scheme, 28nm_, 16nm_, which i
assume is the silicon gate size of the generation.

Reviewed-by: Andrew Lunn <andrew@lunn.ch>

    Andrew
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help