Thread (26 messages) 26 messages, 7 authors, 2025-06-17

Re: [PATCH v5 3/9] arm64: dts: freescale: rename imx93.dtsi to imx91_93_common.dtsi

From: Krzysztof Kozlowski <krzk@kernel.org>
Date: 2025-06-13 10:43:10
Also in: imx, linux-arm-kernel, linux-devicetree, linux-pm, lkml

On 13/06/2025 12:02, Joy Zou wrote:
Rename imx93.dtsi to imx91_93_common.dtsi for adding imx91.dtsi.
Why?

Your commit msg MUST explain that. That's the more important part.
There is no code change.

Add imx93.dtsi, which include imx91_93_common.dtsi.

Signed-off-by: Joy Zou <redacted>
---
 .../boot/dts/freescale/imx91_93_common.dtsi   | 1351 +++++++++++++++++
 arch/arm64/boot/dts/freescale/imx93.dtsi      | 1349 +---------------
Generate patches with proper -M/-B/-C flags so it will be possible to
actually review this.

quoted hunk ↗ jump to hunk
 2 files changed, 1353 insertions(+), 1347 deletions(-)
 create mode 100644 arch/arm64/boot/dts/freescale/imx91_93_common.dtsi
diff --git a/arch/arm64/boot/dts/freescale/imx91_93_common.dtsi b/arch/arm64/boot/dts/freescale/imx91_93_common.dtsi
new file mode 100644
index 000000000000..64cd0776b43d
--- /dev/null
+++ b/arch/arm64/boot/dts/freescale/imx91_93_common.dtsi
@@ -0,0 +1,1351 @@
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
+/*
+ * Copyright 2022 NXP
+ */
+
+#include <dt-bindings/clock/imx93-clock.h>
+#include <dt-bindings/dma/fsl-edma.h>
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/interrupt-controller/arm-gic.h>
+#include <dt-bindings/power/fsl,imx93-power.h>
+#include <dt-bindings/thermal/thermal.h>
+
+#include "imx93-pinfunc.h"
+
+/ {
+	interrupt-parent = <&gic>;
+	#address-cells = <2>;
+	#size-cells = <2>;
+
+	aliases {
+		gpio0 = &gpio1;
+		gpio1 = &gpio2;
+		gpio2 = &gpio3;
+		gpio3 = &gpio4;
+		i2c0 = &lpi2c1;
+		i2c1 = &lpi2c2;
+		i2c2 = &lpi2c3;
+		i2c3 = &lpi2c4;
+		i2c4 = &lpi2c5;
+		i2c5 = &lpi2c6;
+		i2c6 = &lpi2c7;
+		i2c7 = &lpi2c8;
Not common aliases. Drop.

+		mmc0 = &usdhc1;
+		mmc1 = &usdhc2;
+		mmc2 = &usdhc3;
Not common aliases. Drop.

+		serial0 = &lpuart1;
+		serial1 = &lpuart2;
+		serial2 = &lpuart3;
+		serial3 = &lpuart4;
+		serial4 = &lpuart5;
+		serial5 = &lpuart6;
+		serial6 = &lpuart7;
+		serial7 = &lpuart8;
Not common aliases. Drop.
+		spi0 = &lpspi1;
+		spi1 = &lpspi2;
+		spi2 = &lpspi3;
+		spi3 = &lpspi4;
+		spi4 = &lpspi5;
+		spi5 = &lpspi6;
+		spi6 = &lpspi7;
+		spi7 = &lpspi8;
Not common aliases. Drop.


Best regards,
Krzysztof
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help