Thread (29 messages) 29 messages, 4 authors, 2024-12-13

Re: [PATCH net-next v1 00/11] lan78xx: Preparations for PHYlink

flat view

From: patchwork-bot+netdevbpf@kernel.org
Date: 2024-12-11 03:00:14
Also in: lkml

Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski [off-list ref]:

On Mon,  9 Dec 2024 14:07:40 +0100 you wrote:
This patch set is a second part of the preparatory work for migrating
the lan78xx USB Ethernet driver to the PHYlink framework. During
extensive testing, I observed that resetting the USB adapter can lead to
various read/write errors. While the errors themselves are acceptable,
they generate excessive log messages, resulting in significant log spam.
This set improves error handling to reduce logging noise by addressing
errors directly and returning early when necessary.

[...]
Here is the summary with links:
  - [net-next,v1,01/11] net: usb: lan78xx: Add error handling to lan78xx_setup_irq_domain
    https://git.kernel.org/netdev/net-next/c/d354d008255f
  - [net-next,v1,02/11] net: usb: lan78xx: Add error handling to lan78xx_init_mac_address
    https://git.kernel.org/netdev/net-next/c/6f31135894ec
  - [net-next,v1,03/11] net: usb: lan78xx: Add error handling to lan78xx_set_mac_addr
    https://git.kernel.org/netdev/net-next/c/9a46956c72cb
  - [net-next,v1,04/11] net: usb: lan78xx: Add error handling to lan78xx_get_regs
    (no matching commit)
  - [net-next,v1,05/11] net: usb: lan78xx: Simplify lan78xx_update_reg
    https://git.kernel.org/netdev/net-next/c/41b774e4f327
  - [net-next,v1,06/11] net: usb: lan78xx: Fix return value handling in lan78xx_set_features
    https://git.kernel.org/netdev/net-next/c/bf361b18d91e
  - [net-next,v1,07/11] net: usb: lan78xx: Use ETIMEDOUT instead of ETIME in lan78xx_stop_hw
    (no matching commit)
  - [net-next,v1,08/11] net: usb: lan78xx: Use function-specific label in lan78xx_mac_reset
    (no matching commit)
  - [net-next,v1,09/11] net: usb: lan78xx: Improve error handling in lan78xx_phy_wait_not_busy
    https://git.kernel.org/netdev/net-next/c/21fff45a6cc1
  - [net-next,v1,10/11] net: usb: lan78xx: Rename lan78xx_phy_wait_not_busy to lan78xx_mdiobus_wait_not_busy
    (no matching commit)
  - [net-next,v1,11/11] net: usb: lan78xx: Improve error handling in WoL operations
    (no matching commit)

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help