On Mon, 9 Dec 2024 14:07:48 +0100 Oleksij Rempel wrote:
Rename the generic `done` label to the function-specific
`mac_reset_done` label in `lan78xx_mac_reset`. This improves clarity and
aligns with best practices for error handling and cleanup labels.
What rules do you refer to?
AFAIK the best practice for exits is to name the label after what
you're jumping to. In this case I'd use exit_unlock.
quoted hunk ↗ jump to hunk
diff --git a/drivers/net/usb/lan78xx.c b/drivers/net/usb/lan78xx.c
index c66e404f51ac..fdeb95db529b 100644
--- a/drivers/net/usb/lan78xx.c
+++ b/drivers/net/usb/lan78xx.c
@@ -1604,16 +1604,16 @@ static int lan78xx_mac_reset(struct lan78xx_net *dev)
*/
ret = lan78xx_phy_wait_not_busy(dev);
if (ret < 0)
- goto done;
+ goto mac_reset_done;
...
quoted hunk ↗ jump to hunk
ret = -ETIMEDOUT;
-done:
+mac_reset_done:
mutex_unlock(&dev->phy_mutex);
return ret;