Re: [PATCH net-next 2/9] ethtool: Expand Ethernet Power Equipment with PoE alongside PoDL
From: Andrew Lunn <andrew@lunn.ch>
Date: 2023-11-20 22:14:52
Also in:
linux-devicetree, linux-doc, lkml
From: Andrew Lunn <andrew@lunn.ch>
Date: 2023-11-20 22:14:52
Also in:
linux-devicetree, linux-doc, lkml
quoted
However, everything not PoDL PSE seems to be clause 33. So how about: enum ethtool_podl_pse_admin_state podl_admin_control; enum ethtool_c33_pse_admin_state c33_admin_control; At least inside the kernel we use c22, c45, c37 etc. I'm not sure they are visible to userspace, but if we don't have a better name, maybe we have to use c33 in userspace as well. I do think naming like this makes it clear we are talking about two parallel technologies, not a generic layer and then extensions for podl. What do you think?I'm OK with it.
Great.
Köry, can you please include some kernel documentation in your patches? Something like this. I hope it will help to clarify things :) :
This is good. I'm just wondering where to put it. Ideally we want to cross reference to it in both this header file, and in the netlink UAPI. Andrew