RE: [patch V2 09/17] timers: Rename del_timer_sync() to timer_delete_sync()
From: David Laight <hidden>
Date: 2022-11-22 22:23:20
Also in:
linux-bluetooth, lkml
From: David Laight <hidden>
Date: 2022-11-22 22:23:20
Also in:
linux-bluetooth, lkml
From: Thomas Gleixner
Sent: 22 November 2022 17:45 The timer related functions do not have a strict timer_ prefixed namespace which is really annoying. Rename del_timer_sync() to timer_delete_sync() and provide del_timer_sync() as a wrapper. Document that del_timer_sync() is not for new code.
To change the colo[u]r of the bikeshed, would it be better to name the functions timer_start() and timer_stop[_sync](). And, as I found out for a local driver, adding items to work queues from timer callbacks really isn't a good idea at all! The delayed_work functions handle it a lot better. David - Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK Registration No: 1397386 (Wales)