On Thu, Jul 14, 2022 at 12:45:54PM +0200, Krzysztof Kozlowski wrote:
On 12/07/2022 17:59, Russell King (Oracle) wrote:
quoted
quoted
However before implementing this, please wait for more feedback. Maybe
Rob or net folks will have different opinions.
We decided on "pcs-handle" for PCS for several drivers, to be consistent
with the situation for network PHYs (which are "phy-handle", settled on
after we also had "phy" and "phy-device" and decided to deprecate these
two.
Surely we should have consistency within the net code - so either "phy"
and "pcs" or "phy-handle" and "pcs-handle" but not a mixture of both?
True. Then the new property should be "pcs-handle-names"?
IMO, just keep "pcs-handle" and then "pcs-handle-names". We never seem
to get free of the deprecated versions (-gpio).
While just add/remove 's' would be nice, we have to deal with things
like 'mboxes' and I think some other inconsistencies.
Rob