On Wed, May 04, 2022 at 05:33:20PM +0200, Frank Wunderlich wrote:
Hi,
thanks for review
quoted
Gesendet: Mittwoch, 04. Mai 2022 um 17:24 Uhr
Von: "Vladimir Oltean" [off-list ref]
quoted
quoted
+&mdio0 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ switch@0 {
I think the preferable names are the newer "ethernet-switch@0",
"ethernet-ports", "ethernet-port@0".
Otherwise
Reviewed-by: Vladimir Oltean <olteanv@gmail.com>
current device-tree nodes using "switch" and "ports"
see discussioon here about make it fixed to "ports" property instead of PatternProperties including optional "ethernet-"
https://patchwork.kernel.org/project/linux-mediatek/patch/20220502153238.85090-1-linux@fw-web.de/#24843155
Hmm, I don't get why Krzysztof said to just keep what is used in
existing device trees. The schema validator should describe what is
valid, and since the mt7530 driver does not care one way or another
(some drivers do explicitly parse the "ports"/"ethernet-ports" node),
then whatever is valid for the DSA core is also valid for the mt7530
bindings. And "ethernet-ports" is valid too, so I think it should be
accepted by mediatek.yaml...