Hi,
thanks for review
Gesendet: Mittwoch, 04. Mai 2022 um 17:24 Uhr
Von: "Vladimir Oltean" [off-list ref]
quoted
+&mdio0 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ switch@0 {
I think the preferable names are the newer "ethernet-switch@0",
"ethernet-ports", "ethernet-port@0".
Otherwise
Reviewed-by: Vladimir Oltean <olteanv@gmail.com>
current device-tree nodes using "switch" and "ports"
see discussioon here about make it fixed to "ports" property instead of PatternProperties including optional "ethernet-"
https://patchwork.kernel.org/project/linux-mediatek/patch/20220502153238.85090-1-linux@fw-web.de/#24843155
quoted
+ compatible = "mediatek,mt7531";
+ reg = <0>;
+
+ ports {
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ port@1 {
+ reg = <1>;
+ label = "lan0";
+ };
+
+ port@2 {
+ reg = <2>;
+ label = "lan1";
+ };
+
+ port@3 {
+ reg = <3>;
+ label = "lan2";
+ };
+
+ port@4 {
+ reg = <4>;
+ label = "lan3";
+ };
+
+ port@5 {
+ reg = <5>;
+ label = "cpu";
+ ethernet = <&gmac0>;
+ phy-mode = "rgmii";
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ pause;
+ };
+ };
+ };
+ };