Thread (14 messages) flat view 14 messages, 2 authors, 2021-12-08

Re: [PATCH v3 net-next 00/12] Rework DSA bridge TX forwarding offload API

From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-12-08 23:00:16

Hello:

This series was applied to netdev/net-next.git (master)
by Jakub Kicinski [off-list ref]:

On Mon,  6 Dec 2021 18:57:46 +0200 you wrote:
This change set is preparation work for DSA support of bridge FDB
isolation. It replaces struct net_device *dp->bridge_dev with a struct
dsa_bridge *dp->bridge that contains some extra information about that
bridge, like a unique number kept by DSA.

Up until now we computed that number only with the bridge TX forwarding
offload feature, but it will be needed for other features too, like for
isolation of FDB entries belonging to different bridges. Hardware
implementations vary, but one common pattern seems to be the presence of
a FID field which can be associated with that bridge number kept by DSA.
The idea was outlined here:
https://patchwork.kernel.org/project/netdevbpf/patch/20210818120150.892647-16-vladimir.oltean@nxp.com/
(the difference being that with this new proposal, drivers would not
need to call dsa_bridge_num_find, instead the bridge_num would be part
of the struct dsa_bridge :: num passed as argument).

[...]
Here is the summary with links:
  - [v3,net-next,01/12] net: dsa: make dp->bridge_num one-based
    https://git.kernel.org/netdev/net-next/c/3f9bb0301d50
  - [v3,net-next,02/12] net: dsa: assign a bridge number even without TX forwarding offload
    https://git.kernel.org/netdev/net-next/c/947c8746e2c3
  - [v3,net-next,03/12] net: dsa: mt7530: iterate using dsa_switch_for_each_user_port in bridging ops
    https://git.kernel.org/netdev/net-next/c/872bb81dfbc3
  - [v3,net-next,04/12] net: dsa: mv88e6xxx: iterate using dsa_switch_for_each_user_port in mv88e6xxx_port_check_hw_vlan
    https://git.kernel.org/netdev/net-next/c/0493fa7927af
  - [v3,net-next,05/12] net: dsa: mv88e6xxx: compute port vlan membership based on dp->bridge_dev comparison
    https://git.kernel.org/netdev/net-next/c/65144067d360
  - [v3,net-next,06/12] net: dsa: hide dp->bridge_dev and dp->bridge_num in the core behind helpers
    https://git.kernel.org/netdev/net-next/c/36cbf39b5690
  - [v3,net-next,07/12] net: dsa: hide dp->bridge_dev and dp->bridge_num in drivers behind helpers
    https://git.kernel.org/netdev/net-next/c/41fb0cf1bced
  - [v3,net-next,08/12] net: dsa: rename dsa_port_offloads_bridge to dsa_port_offloads_bridge_dev
    https://git.kernel.org/netdev/net-next/c/936db8a2dba2
  - [v3,net-next,09/12] net: dsa: export bridging offload helpers to drivers
    https://git.kernel.org/netdev/net-next/c/6a43cba30340
  - [v3,net-next,10/12] net: dsa: keep the bridge_dev and bridge_num as part of the same structure
    https://git.kernel.org/netdev/net-next/c/d3eed0e57d5d
  - [v3,net-next,11/12] net: dsa: add a "tx_fwd_offload" argument to ->port_bridge_join
    https://git.kernel.org/netdev/net-next/c/b079922ba2ac
  - [v3,net-next,12/12] net: dsa: eliminate dsa_switch_ops :: port_bridge_tx_fwd_{,un}offload
    https://git.kernel.org/netdev/net-next/c/857fdd74fb38

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help