Thread (37 messages) flat view 37 messages, 4 authors, 2021-11-10

Re: [RFC PATCH v3 6/8] leds: trigger: add hardware-phy-activity trigger

From: Andrew Lunn <andrew@lunn.ch>
Date: 2021-11-10 22:32:28
Also in: linux-devicetree, linux-doc, linux-leds, lkml

On Wed, Nov 10, 2021 at 09:04:34PM +0100, Ansuel Smith wrote:
On Tue, Nov 09, 2021 at 10:09:40PM +0100, Andrew Lunn wrote:
quoted
quoted
quoted
+/* Expose sysfs for every blink to be configurable from userspace */
+DEFINE_OFFLOAD_TRIGGER(blink_tx, BLINK_TX);
+DEFINE_OFFLOAD_TRIGGER(blink_rx, BLINK_RX);
+DEFINE_OFFLOAD_TRIGGER(keep_link_10m, KEEP_LINK_10M);
+DEFINE_OFFLOAD_TRIGGER(keep_link_100m, KEEP_LINK_100M);
+DEFINE_OFFLOAD_TRIGGER(keep_link_1000m, KEEP_LINK_1000M);
You might get warnings about CamelCase, but i suggest keep_link_10M,
keep_link_100M and keep_link_1000M. These are megabits, not millibits.
quoted
quoted
+DEFINE_OFFLOAD_TRIGGER(keep_half_duplex, KEEP_HALF_DUPLEX);
+DEFINE_OFFLOAD_TRIGGER(keep_full_duplex, KEEP_FULL_DUPLEX);
What does keep mean in this context?
LED is turned on but doesn't blink. Hint for a better name?
I would just drop the keep. You have blink_ as a prefix for those
modes that blink.

      Andrew
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help