On Wed, 3 Mar 2021 at 18:21, Cong Wang [off-list ref] wrote:
Yeah, I am not surprised we can change tcp_update_ulp() too, but
why should I bother kTLS when I do not have to? What you suggest
could at most save us a bit of code size, not a big gain. So, I'd keep
its return value as it is, unless you see any other benefits.
I think the end result is code that is easier to understand and
therefore maintain. Keep it as it is if you prefer.
BTW, I will rename it to 'psock_update_sk_prot', please let me know
if you have any better names.
SGTM.
--
Lorenz Bauer | Systems Engineer
6th Floor, County Hall/The Riverside Building, SE1 7PB, UK
www.cloudflare.com