Thread (13 messages) flat view 13 messages, 2 authors, 2021-02-13

Re: [Patch bpf-next v2 2/5] skmsg: get rid of struct sk_psock_parser

From: Cong Wang <hidden>
Date: 2021-02-13 01:59:02
Also in: bpf

On Fri, Feb 12, 2021 at 11:09 AM Cong Wang [off-list ref] wrote:
On Fri, Feb 12, 2021 at 2:56 AM Lorenz Bauer [off-list ref] wrote:
quoted
On Wed, 10 Feb 2021 at 02:21, Cong Wang [off-list ref] wrote:
quoted
From: Cong Wang <redacted>

struct sk_psock_parser is embedded in sk_psock, it is
unnecessary as skb verdict also uses ->saved_data_ready.
We can simply fold these fields into sk_psock, and get rid
of ->enabled.
Looks nice, can you use sk_psock_strp_enabled() more? There are a
couple places in sock_map.c which test psock->saved_data_ready
directly.
Its name tells it is for stream parser, so not suitable for others.

Are you suggesting to rename it to sk_psock_enabled() and use
it? Note it still has an additional !psock test, but I think that is fine
for slow paths.
Well, I think it is a bug, sk_psock_strp_enabled() probably means
to check whether progs.stream_verdict is running, not whether
any of these progs is running. So, I'd leave this untouched in this
patchset and if needed a separate bug fix should be sent to -net.

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help