On Fri, Feb 12, 2021 at 2:56 AM Lorenz Bauer [off-list ref] wrote:
On Wed, 10 Feb 2021 at 02:21, Cong Wang [off-list ref] wrote:
quoted
From: Cong Wang <redacted>
struct sk_psock_parser is embedded in sk_psock, it is
unnecessary as skb verdict also uses ->saved_data_ready.
We can simply fold these fields into sk_psock, and get rid
of ->enabled.
Looks nice, can you use sk_psock_strp_enabled() more? There are a
couple places in sock_map.c which test psock->saved_data_ready
directly.
Its name tells it is for stream parser, so not suitable for others.
Are you suggesting to rename it to sk_psock_enabled() and use
it? Note it still has an additional !psock test, but I think that is fine
for slow paths.
Thanks.