Thread (14 messages) 14 messages, 2 authors, 2021-01-25

Re: [PATCH bpf-next 00/12] Various cleanups/fixes for AF_XDP selftests

From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-01-25 23:12:08
Also in: bpf

Hello:

This series was applied to bpf/bpf-next.git (refs/heads/master):

On Fri, 22 Jan 2021 16:47:13 +0100 you wrote:
This series is a number of fixes/cleanups, mainly to improve the
readability of the xdpxceiver selftest application.

Details in each commit!


Cheers,
Björn

[...]
Here is the summary with links:
  - [bpf-next,01/12] selftests/bpf: remove a lot of ifobject casting
    https://git.kernel.org/bpf/bpf-next/c/7140ef14007e
  - [bpf-next,02/12] selftests/bpf: remove unused enums
    https://git.kernel.org/bpf/bpf-next/c/449f0874fd4e
  - [bpf-next,03/12] selftests/bpf: fix style warnings
    https://git.kernel.org/bpf/bpf-next/c/a86072838b67
  - [bpf-next,04/12] selftests/bpf: remove memory leak
    https://git.kernel.org/bpf/bpf-next/c/4896d7e37ea5
  - [bpf-next,05/12] selftests/bpf: improve readability of xdpxceiver/worker_pkt_validate()
    https://git.kernel.org/bpf/bpf-next/c/8a9cba7ea858
  - [bpf-next,06/12] selftests/bpf: remove casting by introduce local variable
    https://git.kernel.org/bpf/bpf-next/c/0b50bd48cfe7
  - [bpf-next,07/12] selftests/bpf: change type from void * to struct ifaceconfigobj *
    https://git.kernel.org/bpf/bpf-next/c/124000e48b7e
  - [bpf-next,08/12] selftests/bpf: change type from void * to struct generic_data *
    https://git.kernel.org/bpf/bpf-next/c/59a4a87e4b26
  - [bpf-next,09/12] selftests/bpf: define local variables at the beginning of a block
    https://git.kernel.org/bpf/bpf-next/c/829725ec7bf5
  - [bpf-next,10/12] selftests/bpf: avoid heap allocation
    https://git.kernel.org/bpf/bpf-next/c/93dd4a06c0e3
  - [bpf-next,11/12] selftests/bpf: consistent malloc/calloc usage
    https://git.kernel.org/bpf/bpf-next/c/d08a17d6de20
  - [bpf-next,12/12] selftests/bpf: avoid useless void *-casts
    https://git.kernel.org/bpf/bpf-next/c/095af986525a

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help