Thread (14 messages) 14 messages, 2 authors, 2021-01-25
STALE1982d

[PATCH bpf-next 00/12] Various cleanups/fixes for AF_XDP selftests

From: Björn Töpel <hidden>
Date: 2021-01-22 17:21:40
Also in: bpf

This series is a number of fixes/cleanups, mainly to improve the
readability of the xdpxceiver selftest application.

Details in each commit!


Cheers,
Björn

Björn Töpel (12):
  selftests/bpf: remove a lot of ifobject casting
  selftests/bpf: remove unused enums
  selftests/bpf: fix style warnings
  selftests/bpf: remove memory leak
  selftests/bpf: improve readability of xdpxceiver/worker_pkt_validate()
  selftests/bpf: remove casting by introduce local variable
  selftests/bpf: change type from void * to struct ifaceconfigobj *
  selftests/bpf: change type from void * to struct generic_data *
  selftests/bpf: define local variables at the beginning of a block
  selftests/bpf: avoid heap allocation
  selftests/bpf: consistent malloc/calloc usage
  selftests/bpf: avoid useless void *-casts

 tools/testing/selftests/bpf/xdpxceiver.c | 219 +++++++++++------------
 tools/testing/selftests/bpf/xdpxceiver.h |   2 -
 2 files changed, 105 insertions(+), 116 deletions(-)


base-commit: 443edcefb8213155c0da22c4a999f4a49858fa39
-- 
2.27.0
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help