On Wed Oct 21 2020, Florian Fainelli wrote:
On 10/21/2020 5:16 PM, Vladimir Oltean wrote:
quoted
On Wed, Oct 21, 2020 at 08:52:01AM +0200, Kurt Kanzenbach wrote:
quoted
On Mon Oct 19 2020, Christian Eggers wrote:
The node names should be switch. See dsa.yaml.
quoted
+ compatible = "microchip,ksz9477";
+ reg = <0>;
+ reset-gpios = <&gpio5 0 GPIO_ACTIVE_LOW>;
+
+ spi-max-frequency = <44000000>;
+ spi-cpha;
+ spi-cpol;
+
+ ports {
ethernet-ports are preferred.
This is backwards to me, instead of an 'ethernet-switch' with 'ports',
we have a 'switch' with 'ethernet-ports'. Whatever.
The rationale AFAIR was that dual Ethernet port controllers like TI's
CPSW needed to describe each port as a pseudo Ethernet MAC and using
'ethernet-ports' as a contained allowed to disambiguate with the 'ports'
container used in display subsystem descriptions.
Yes, that was the outcome of previous discussions.
We should probably enforce or recommend 'ethernet-switch' to be used
as the node name for Ethernet switch devices though.
After using grep, it seems like 'ethernet-switch' as well as simply
'switch' are being used today. Yes, maybe both should be allowed.
Thanks,
Kurt