Hi Andrew,
On Mon, 21 Oct 2019 14:31:49 +0200, Andrew Lunn [off-list ref] wrote:
On Sat, Oct 19, 2019 at 11:19:26PM -0400, Vivien Didelot wrote:
quoted
Do not let the drivers access the ds->ports static array directly
while there is a dsa_to_port helper for this purpose.
At the same time, un-const this helper since the SJA1105 driver
assigns the priv member of the returned dsa_port structure.
Hi Vivien
Is priv the only member we expect drivers to change? Is the rest
private to the core/RO? Rather then remove the const, i wonder if it
would be better to add a helper to set priv?
Otherwise:
Reviewed-by: Andrew Lunn <andrew@lunn.ch>
I had the same thought but actually since the SJA1105 driver is the only
user, I was thinking about maybe getting rid of it, I don't really see the
point of having some "dp->priv = priv, priv->dp = dp" kind of code...
In the meantime I kept the eventual helper or priv removal for a future series.
Thank you,
Vivien