Thread (44 messages) flat view 44 messages, 4 authors, 2019-10-21

Re: [PATCH net-next 01/16] net: dsa: use dsa_to_port helper everywhere

From: Andrew Lunn <andrew@lunn.ch>
Date: 2019-10-21 12:31:54
Also in: lkml

On Sat, Oct 19, 2019 at 11:19:26PM -0400, Vivien Didelot wrote:
Do not let the drivers access the ds->ports static array directly
while there is a dsa_to_port helper for this purpose.

At the same time, un-const this helper since the SJA1105 driver
assigns the priv member of the returned dsa_port structure.
Hi Vivien

Is priv the only member we expect drivers to change? Is the rest
private to the core/RO? Rather then remove the const, i wonder if it
would be better to add a helper to set priv?

Otherwise:

Reviewed-by: Andrew Lunn <andrew@lunn.ch>

    Andrew
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help