Re: [PATCH] once: switch to new jump label API
flat view
From: Daniel Borkmann <daniel@iogearbox.net>
Date: 2017-10-09 21:14:58
Also in:
lkml
On 10/09/2017 10:27 PM, Eric Biggers wrote:
On Fri, Sep 15, 2017 at 09:07:51PM -0700, Eric Biggers wrote:quoted
On Tue, Aug 22, 2017 at 02:44:41PM -0400, Hannes Frederic Sowa wrote:quoted
Eric Biggers [off-list ref] writes:quoted
From: Eric Biggers <redacted> Switch the DO_ONCE() macro from the deprecated jump label API to the new one. The new one is more readable, and for DO_ONCE() it also makes the generated code more icache-friendly: now the one-time initialization code is placed out-of-line at the jump target, rather than at the inline fallthrough case. Signed-off-by: Eric Biggers <redacted>Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org. Thanks!Great! Who though is the maintainer for this code? It seems it was originally taken by David Miller through the networking tree. David, are you taking further patches to the "once" functions, or should I be trying to get this into -mm, or somewhere else? EricPing.
Given original code was accepted against net-next tree as major users of the api are networking related anyway, it should be fine here as well to route through this tree. Maybe resend the patch with a [PATCH net-next] in the subject line (as usually done) to make the targeted tree more clear.