Re: [PATCH] once: switch to new jump label API

From
Eric Biggers <hidden>
Date
2017-09-16 04:07:59
Also in
lkml
Reply to
Hannes Frederic Sowa, 2017-08-22
On Tue, Aug 22, 2017 at 02:44:41PM -0400, Hannes Frederic Sowa wrote:
Eric Biggers [off-list ref] writes:
quoted
From: Eric Biggers <redacted>

Switch the DO_ONCE() macro from the deprecated jump label API to the new
one.  The new one is more readable, and for DO_ONCE() it also makes the
generated code more icache-friendly: now the one-time initialization
code is placed out-of-line at the jump target, rather than at the inline
fallthrough case.

Signed-off-by: Eric Biggers <redacted>
Acked-by: Hannes Frederic Sowa <<redacted>

Thanks!
Great!  Who though is the maintainer for this code?  It seems it was originally
taken by David Miller through the networking tree.  David, are you taking
further patches to the "once" functions, or should I be trying to get this into
-mm, or somewhere else?

Eric
Thread (5 messages) 5 messages, 4 authors, last reply 2017-10-09
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help