From: Hannes Frederic Sowa <hidden> Date: 2017-08-22 18:44:45
Eric Biggers [off-list ref] writes:
From: Eric Biggers <redacted>
Switch the DO_ONCE() macro from the deprecated jump label API to the new
one. The new one is more readable, and for DO_ONCE() it also makes the
generated code more icache-friendly: now the one-time initialization
code is placed out-of-line at the jump target, rather than at the inline
fallthrough case.
Signed-off-by: Eric Biggers <redacted>
Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org.
Thanks!
From: Eric Biggers <hidden> Date: 2017-09-16 04:07:59
On Tue, Aug 22, 2017 at 02:44:41PM -0400, Hannes Frederic Sowa wrote:
Eric Biggers [off-list ref] writes:
quoted
From: Eric Biggers <redacted>
Switch the DO_ONCE() macro from the deprecated jump label API to the new
one. The new one is more readable, and for DO_ONCE() it also makes the
generated code more icache-friendly: now the one-time initialization
code is placed out-of-line at the jump target, rather than at the inline
fallthrough case.
Signed-off-by: Eric Biggers <redacted>
Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org.
Thanks!
Great! Who though is the maintainer for this code? It seems it was originally
taken by David Miller through the networking tree. David, are you taking
further patches to the "once" functions, or should I be trying to get this into
-mm, or somewhere else?
Eric
From: Eric Biggers <hidden> Date: 2017-10-09 20:27:12
On Fri, Sep 15, 2017 at 09:07:51PM -0700, Eric Biggers wrote:
On Tue, Aug 22, 2017 at 02:44:41PM -0400, Hannes Frederic Sowa wrote:
quoted
Eric Biggers [off-list ref] writes:
quoted
From: Eric Biggers <redacted>
Switch the DO_ONCE() macro from the deprecated jump label API to the new
one. The new one is more readable, and for DO_ONCE() it also makes the
generated code more icache-friendly: now the one-time initialization
code is placed out-of-line at the jump target, rather than at the inline
fallthrough case.
Signed-off-by: Eric Biggers <redacted>
Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org.
Thanks!
Great! Who though is the maintainer for this code? It seems it was originally
taken by David Miller through the networking tree. David, are you taking
further patches to the "once" functions, or should I be trying to get this into
-mm, or somewhere else?
Eric
From: Daniel Borkmann <daniel@iogearbox.net> Date: 2017-10-09 21:14:58
On 10/09/2017 10:27 PM, Eric Biggers wrote:
On Fri, Sep 15, 2017 at 09:07:51PM -0700, Eric Biggers wrote:
quoted
On Tue, Aug 22, 2017 at 02:44:41PM -0400, Hannes Frederic Sowa wrote:
quoted
Eric Biggers [off-list ref] writes:
quoted
From: Eric Biggers <redacted>
Switch the DO_ONCE() macro from the deprecated jump label API to the new
one. The new one is more readable, and for DO_ONCE() it also makes the
generated code more icache-friendly: now the one-time initialization
code is placed out-of-line at the jump target, rather than at the inline
fallthrough case.
Signed-off-by: Eric Biggers <redacted>
Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org.
Thanks!
Great! Who though is the maintainer for this code? It seems it was originally
taken by David Miller through the networking tree. David, are you taking
further patches to the "once" functions, or should I be trying to get this into
-mm, or somewhere else?
Eric
Ping.
Given original code was accepted against net-next tree as major users of
the api are networking related anyway, it should be fine here as well to
route through this tree. Maybe resend the patch with a [PATCH net-next]
in the subject line (as usually done) to make the targeted tree more clear.
From: David Miller <davem@davemloft.net> Date: 2017-10-09 21:17:31
From: Daniel Borkmann <daniel@iogearbox.net>
Date: Mon, 09 Oct 2017 23:14:42 +0200
Given original code was accepted against net-next tree as major
users of the api are networking related anyway, it should be fine
here as well to route through this tree. Maybe resend the patch with
a [PATCH net-next] in the subject line (as usually done) to make the
targeted tree more clear.