Thread (22 messages) 22 messages, 7 authors, 2016-09-13

Re: [PATCH 12/15] sis900: use IS_ENABLED() instead of checking for built-in or module

flat view

From: Daniele Venzano <venza@brownhat.org>
Date: 2016-09-12 17:19:04
Also in: lkml


On 12 September 2016 16:03:43 CEST, Javier Martinez Canillas [off-list ref] wrote:
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled
either
built-in or as a module, use that macro instead of open coding the
same.

Using the macro makes the code more readable by helping abstract away
some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <redacted>
Acked-by: Daniele Venzano <venza@brownhat.org>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help