Thread (22 messages) 22 messages, 7 authors, 2016-09-13

Re: [PATCH 11/15] sfc: use IS_ENABLED() instead of checking for built-in or module

flat view

From: Bert Kenward <hidden>
Date: 2016-09-12 14:39:23
Also in: lkml

On 12/09/16 15:03, Javier Martinez Canillas wrote:
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <redacted>
Acked-by: Bert Kenward <redacted>

Thanks,

Bert.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help