Re: [PATCH net-next v4 2/3] bpf: Add bpf_current_task_under_cgroup helper
From: Alexei Starovoitov <hidden>
Date: 2016-08-12 15:21:26
On Fri, Aug 12, 2016 at 09:29:35AM -0400, Tejun Heo wrote:
Hello, On Fri, Aug 12, 2016 at 09:40:39AM +0200, Daniel Borkmann wrote:quoted
quoted
I actually wish we could rename skb_in_cgroup to skb_under_cgroup. If we ever introduced a check for absolute membership versus ancestral membership, what would we call that?That option is, by the way, still on the table for -net tree, since 4.8 is not released yet, so it could still be renamed into BPF_FUNC_skb_under_cgroup. Then you could make this one here for -net-next as "BPF_FUNC_current_under_cgroup". Tejun, Alexei?lol I should have read the whole thread before replying twice. Sorry about that. Yeah, if we can still rename it, let's do "under". It's more intuitive and gives us the room to implement the real "in" test if ever necessary in the future.
agree. Thanks for explaining 'in' vs 'under' terminology. since we can still rename skb_in_cgroup we should do it. and since that was my only nit for this patch. Acked-by: Alexei Starovoitov <ast@kernel.org> All 3 patches should go via net-next and to avoid conflicts 1/3 can be in cgroup tree as well (if you think there will be conflicts). We did that in the past with tip and net-next and it worked out well. Daniel or Martin, do you mind preparing in->under renaming patch for net? Thanks!