Thread (11 messages) flat view 11 messages, 4 authors, 2016-08-12

Re: [PATCH net-next v4 2/3] bpf: Add bpf_current_task_under_cgroup helper

From: Tejun Heo <tj@kernel.org>
Date: 2016-08-12 13:29:37

Hello,

On Fri, Aug 12, 2016 at 09:40:39AM +0200, Daniel Borkmann wrote:
quoted
I actually wish we could rename skb_in_cgroup to skb_under_cgroup. If we ever
introduced a check for absolute membership versus ancestral membership, what
would we call that?
That option is, by the way, still on the table for -net tree, since 4.8 is not
released yet, so it could still be renamed into BPF_FUNC_skb_under_cgroup.

Then you could make this one here for -net-next as "BPF_FUNC_current_under_cgroup".

Tejun, Alexei?
lol I should have read the whole thread before replying twice.  Sorry
about that.  Yeah, if we can still rename it, let's do "under".  It's
more intuitive and gives us the room to implement the real "in" test
if ever necessary in the future.

Thanks.

-- 
tejun
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help