On Fri, Aug 12, 2016 at 09:21:39AM -0400, Tejun Heo wrote:
On Thu, Aug 11, 2016 at 09:50:48PM -0700, Sargun Dhillon wrote:
quoted
I realize that in_cgroup is more consistent, but under_cgroup makes
far more sense to me. I think it's more intuitive.
So, I think in_cgroup should mean that the object is in that
particular cgroup while under_cgroup in the subhierarchy of that
cgroup. Let's rename the other subhierarchy test to under too. I
think that'd be a lot less confusing going forward.
Ah, I suppose the bpf part is userland visible? If so, there isn't
much we can do and probably best to stick with in_cgroup for that
part. Bummer but no big deal.
Thanks.
--
tejun