On 07/01/16 18:51, Tom Herbert wrote:
On Thu, Jan 7, 2016 at 9:13 AM, Edward Cree [off-list ref] wrote:
quoted
@@ -787,7 +786,7 @@ int fou_build_header(struct sk_buff *skb, struct ip_tunnel_encap *e,
int type = csum ? SKB_GSO_UDP_TUNNEL_CSUM : SKB_GSO_UDP_TUNNEL;
__be16 sport;
- skb = iptunnel_handle_offloads(skb, csum, type);
+ skb = iptunnel_handle_offloads(skb, false, type);
It might good to have another iptunnel_handle_offloads (lifke
iptunnel_handle_offloads_nocsum) function that doesn't have csum
parameter for readability.
I hope to follow up soon with a patch to use LCO for GRE, at which point I
believe that all callers will be passing false anyway, so the csum_help
parameter can be removed from the function entirely.
-ed