Thread (21 messages) 21 messages, 5 authors, 2013-04-23

Re: [PATCH 2/2] thermal: shorten too long mcast group name

From: Masatake YAMATO <hidden>
Date: 2013-03-22 03:43:13
Also in: linux-acpi

Sorry for cross posting to netdev and linux-acpi.

I submitted almost same patch about thermal subsystem both netdev list
and then linux-acpi list.

http://marc.info/?l=linux-netdev&m=136371412725264&w=2
http://marc.info/?l=linux-acpi&m=136386050309109&w=2

After submitting to linux-acpi list, I noticed the patch
is merged to a tree davem maintained.

What I should do?

The submitted pathes are bit different.
In netdev, I proposed changing "thermal_mc_group" to
"thermal_mc_grp". In linux-acpi I proposed changing 
"thermal_mc_group" to "thermal_mc_grou".

"thermal_mc_grp" is easier to read. However, when thinking
about compatibility, "thermal_mc_grou" is better.

I've already submitted another patch for genl command which 
truncates the C string returned from kernel.

http://marc.info/?l=linux-netdev&m=136371412625262&w=2

Consider a situation(A); using old kernel(without my patch submitted for linux-acpi)
and new genl command (with my patch for genl). You will get

   thermal_mc_grou

as output.


Consider anther situation(B); using new kernel(with my patch submitted for 
linux-acpi) and old genl command (without my patch for genl). You will get

   thermal_mc_grou

as output. In both situations(A and B) users can get the same output.
If you choose "thermal_mc_grp", users may see "thermal_mc_grp" or
"thermal_mc_grou".
quoted
quoted
From: Masatake YAMATO <redacted>
Date: Tue, 19 Mar 2013 20:47:28 +0900
quoted
The original name is too long.

Signed-off-by: Masatake YAMATO <redacted>
This change needs to go in via the Thermal driver maintainers.
Thanks. I've submitted the patch to linux-acpi ML.
I already applied the patch to my tree, didn't you read
the rest of this thread?
I read but I didn't understand the meaning of applying because
I cannot find my 2nd patch for thermal in net-next tree when I 
pulled.

What I should do? Should I withdraw the patch submitted to 
linux-acpi?

However, I slight modified the patch when I submitted it to 
linux-acpi.
And in the future, order your patches such that you fix the bug before
adding the assertion.
Sorry. I'll do so next time.

Masatake YAMATO
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help