Thread (22 messages) 22 messages, 6 authors, 2012-09-17

RE: [net-next 4/6] igb: Store the MAC address in the name in the PTP struct.

flat view

From: "Keller, Jacob E" <jacob.e.keller@intel.com>
Date: 2012-09-06 23:24:42

-----Original Message-----
From: Ben Hutchings [mailto:bhutchings@solarflare.com]
Sent: Thursday, September 06, 2012 4:23 PM
To: Keller, Jacob E; Richard Cochran
Cc: Kirsher, Jeffrey T; davem@davemloft.net; Vick, Matthew;
netdev@vger.kernel.org; gospo@redhat.com; sassmann@redhat.com
Subject: RE: [net-next 4/6] igb: Store the MAC address in the name in the
PTP struct.

On Thu, 2012-09-06 at 22:59 +0000, Keller, Jacob E wrote:
quoted
quoted
-----Original Message-----
From: netdev-owner@vger.kernel.org
[mailto:netdev-owner@vger.kernel.org]
On Behalf Of Richard Cochran
Sent: Thursday, September 06, 2012 1:06 AM
To: Kirsher, Jeffrey T
Cc: davem@davemloft.net; Vick, Matthew; netdev@vger.kernel.org;
gospo@redhat.com; sassmann@redhat.com
Subject: Re: [net-next 4/6] igb: Store the MAC address in the name
in the PTP struct.

On Wed, Sep 05, 2012 at 04:35:04PM -0700, Jeff Kirsher wrote:
quoted
From: Matthew Vick <redacted>

Change the name of the adapter in the PTP struct to enable easier
correlation between interface and PTP device.
Still think it is better to have the driver name, not the MAC address.
The correlation is clear by using the ethtool method.
I found a method to correct the init code so that the device name can
appear here, and I would prefer that over either the driver name or
MAC address. It requires moving the ptp initialization into the netdev
open handler though.
I don't think you should use the net device name for this, as net devices
can be renamed after creation.  (Though you could update the struct
ptp_clock_info whenever this happens.)

I'm starting to wonder what use there is for a 'clock name' distinct from
the clock device name.  What would be more useful is to give it a parent.
Richard, is there any reason why ptp_clock_register() doesn't allow
specifying the parent device?  You can then make the clock_name attribute
contain the parent device's driver name or whatever it is you prefer.

Ben.
Because ideally the ptp device belongs to multiple ethernet devices...

Sadly current intel hardware doesn't support this.

- Jake
--
Ben Hutchings, Staff Engineer, Solarflare Not speaking for my employer;
that's the marketing department's job.
They asked us to note that Solarflare product names are trademarked.
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help