Re: [PATCH net-next] tcp: unalias tcp_skb_cb flags and ip_dsfield
flat view
From: Christoph Paasch <hidden>
Date: 2011-09-27 07:37:44
Hi, I realize that before "struct tcp_skb_cb" is a comment saying that it's 44 bytes long. However, (as far as I can see) before Eric's change it was 42 bytes long and now it became 43 bytes. Wouldn't it make sense to change the comment, so that it's consistent again with the real size of tcp_skb_cb ? Cheers, Christoph On Tuesday 27 September 2011 wrote David Miller:
From: Eric Dumazet <redacted> Date: Tue, 27 Sep 2011 08:00:49 +0200quoted
struct tcp_skb_cb contains a "flags" field containing either tcp flags or IP dsfield depending on context (input or output path) Introduce ip_dsfield to make the difference clear and ease maintenance. If later we want to save space, we can union flags/ip_dsfield Signed-off-by: Eric Dumazet <redacted>Applied, thanks Eric.quoted
If there is no objection, I plan to rename "flags" to "tcp_flags" in a following patch.No objections. -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
-- Christoph Paasch PhD Student IP Networking Lab --- http://inl.info.ucl.ac.be MultiPath TCP in the Linux Kernel --- http://inl.info.ucl.ac.be/mptcp Université Catholique de Louvain www.rollerbulls.be --